Recent Notes

Displaying keyword search results 1 - 3
Created by Fang on February 08, 2012 21:15:00    Last update: February 08, 2012 21:15:00
This was the error message: [ERROR] sun.security.validator.ValidatorExceptio... The certificate was actually signed by Verisign, but somehow failed to pass Java cert validation. To resolve the problem: Download the cert from the server (with RetrieveSSLCert , for example) Import the certificate into the keystore: $ keytool -import -trustcacerts -alias myserver -f... Define MAVEN_OPTS : $ export MAVEN_OPTS='-Djavax.net.ssl.trustStore=/h... The quotes must exist for the value of MAVEN_OPTS , and the path must be absolute ( ~/etc/mavenKeyStore.jks does not work).
Created by magnum on May 06, 2011 12:26:14    Last update: May 06, 2011 12:26:14
The bash environment variable PROMPT_COMMAND contains a regular bash command that is executed just before the command prompt is displayed. For example: $ export PROMPT_COMMAND=a bash: a: command not ... The command a is not valid so you get the error message every time you hit enter. Echo something before $PS1 : $ export PROMPT_COMMAND='echo -n Hi!' Hi!$ ... PROMPT_COMMAND is regularly used to change the xterm window title. You may find this in /etc/bashrc : case $TERM in xterm*) if [ -...
Created by voodoo on February 25, 2011 14:00:41    Last update: February 25, 2011 14:03:46
Suddenly my Windows XP failed to boot with this error message on a blank screen: missing or corrupt <windows root>\system32\hal.dll I took out the hard drive, put it in a USB enclosure and attached it to another PC. Then I ran CHKDSK and it fixed some file system errors. But I did find that hal.dll was intact, so hal.dll was not missing or corrupt . It turned out that the file that was really missing was C:\boot.ini . It is a hidden file, so you have to use attrib boot.ini to see it. The file is missing if attrib boot.ini returns nothing (run in the root folder C:\). In my case I reconstructed the boot.ini file: [boot loader] timeout=30 default=multi(0)dis... and changed the attributes back...