Maven: class file has wrong version 50.0, should be 49.0 

Joined:
08/13/2009
Posts:
172

March 30, 2011 15:31:24    Last update: March 30, 2011 15:31:24
You get this error when you are trying to compile with JDK 1.5 (class version 49), but your dependency was compiled by JDK 1.6 (class version 50). Check the JAVA_HOME setting, and make sure it's pointing to JDK 1.6. On Unix, use
set | grep -i java_home


On Windows, just
set JAVA_HOME
Share |
| Comment  | Tags