Maven Error assembling EJB: META-INF/ejb-jar.xml is required for ejbVersion 2.x 

Joined:
08/13/2009
Posts:
172

September 08, 2009 03:40:22    Last update: January 10, 2010 00:19:17
The Maven EJB plugin defaults to version 2.1. You get this error when you try to assemble an EJB without a corresponding ejb-jar.xml:
[INFO] Error assembling EJB: META-INF/ejb-jar.xml is required for ejbVersion 2.x


If you are targeting EJB 3, you should add this to pom.xml:
<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-ejb-plugin</artifactId>
            <configuration>
                <ejbVersion>3.0</ejbVersion>
            </configuration>
        </plugin>
    </plugins>
</build>


Reference: Maven EJB plugin.
Share |
| Comment  | Tags